1 (edited by kdadmin 2021-04-29 17:07:25)

Topic: Installing PhpBB 3.3.3

Attempting to install phpBB-3.3.3.
Requires PHP 7.1.3+ and MySQL 4.1.3.

During installation phpBB complains PHP 7.1.3 or higher is not available.

The Tux FAQ mentions:

In order to execute PHP7 instead of PHP5, edit/add a .htaccess file and add:
   AddType application/x-httpd-php7 .php

If that is the fix, where do I place this .htaccess file? I cannot find an existing one anywhere. And is it simply a file named .htaccess with the single line: "AddType application/x-httpd-php7 .php"  ?

I can use a different BB if needed.

Thanks much,

Update:
I abandoned the phpBB-3.3.3 effort.
Installed punbb-1.4.6 instead - much smaller.

Another update:
Cannot get punbb-1.4.6 to work via https.
Loggins are unsecure.

Is there a fix for this?

Any help would be appreciated.

Thanks,

Re: Installing PhpBB 3.3.3

kdadmin wrote:

If that is the fix, where do I place this .htaccess file?

Typically in the same directory as your phpBB/pubBB installation.

kdadmin wrote:

I cannot find an existing one anywhere.

How do you list files? Most PHP software come with a .htaccess file, typically filled with various RewriteRules. However, filenames that start with a dot are considered hidden files and may not be displayed unless explicitly requested.

kdadmin wrote:

And is it simply a file named .htaccess with the single line: "AddType application/x-httpd-php7 .php"  ?

Absolutely. *.htaccess files are not specific to TuxFamily (they are specific to the Apache web server though); there is plenty of documentation on the Internet about them.

kdadmin wrote:

Loggins are unsecure.
Is there a fix for this?

As I am writing this message, both https://forum.dslav.tuxfamily.org/ and https://dslav.tuxfamily.org/ are considered secure. The fix was to... wait for the morning. Explanation: TLS/X.509 certificates are not requested immediately, so there is a one-day delay during which your freshly spawned web area is not considered secure over HTTPS.