1 (edited by librefan 2016-03-08 10:03:54)

Topic: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Drupal 8 a en définitive besoin de PHP 5.5.9, cela a changé en juillet 2015.

J'imagine que pour que Tuxfamily ait cette version de PHP, il faudrait faire passer les serveurs à Debian Jessie qui offre PHP5 en version 5.6.14?

aïe

et voir les autres https://forum.tuxfamily.org/post/2938/#p2938

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Salut librefan,

Merci pour l'info et en effet cela fait remonter l'upgrade dans la TODO.

Apparemment les 'premiers essais' se sont plutôt bien passés, pour le reste, à part dire que gradator va sans doute nous programmer cela pour dans 'pas trop longtemps', je ne sais rien de plus.

Marc

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Merci Marck,

On attend donc bien tranquillement la suite des événements. D'ailleurs, Drupal 8 aura une mise à jour (8.1.0) courant mi-avril, donc ça laisse un peu de temp :-)

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Merci à librefan pour l'info.
Je m'abonne à ce fil car j'administre un site Drupal v7.41 et j'attends que l'architecture de TuxFamily soit compatible pour passer à Drupal v8.
Cordialement,

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Et je dirais même plus ;-) , il faut aussi attendre que les modules utilisés soient portés sur Drupal 8.

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Après votre coup de baguette magique TLS, vous allez sûrement bientôt commencer à vous ennuyer un petit peu ;-) — alors je profite de mon passage sur le forum pour en remettre une louche.

Wordpress n'est plus censé fonctionner avec PHP 5.4 même s'il a l'air d'aller bien chez TF.
Et maintenant, c'est au tour d'un module de WP, le seul antispam qui a vraiment l'air de marcher: WP-Spamshield annonce qu'ils vont larguer les vieux PHP. Je ne sais pas comment remplacer cet antispam efficace qui ne gêne pas les internautes, et qui, apparemment, ne les espionne pas comme Google captcha ou Akismet.

Tout ça pour dire que Debian Jessie paraît être un bon investissement et si les premiers essais ont été encourageants comme le dit Marck, eh bien, c'est … encourageant ;-)

Bon courage en attendant pour le boulot quotidien

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

La fin de Debian Wheezy est programmée pour fin avril 2016, donc bon, plus que s'ennuyer, on a surtout pas vraiment le choix, on doit passer en Jessie dans les 2 mois à venir. :-)

En vrai, tout le boulot préparatoire est déjà fait (paquets maison, vérification de la compatibilité avec VHFFS), reste plus qu'a faire.

Sylvain

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Merci pour ta réponse, gradator, et on croise les doigts pour que tout se passe sans trop de mal pour l'équipe.

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Et hop, c'est fait :)

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

Ah, mais cette nouvelle n’est même pas sur la page des news, et je l’ai ratée.

Félicitations, en tous cas — tout a l’air de bien marcher puisque personne n’a l’air de se plaindre ;-)

Re: Drupal 8, WordPress, WP-Spamshield: PHP 5.5 ou supérieur

"tout a l’air de bien marcher puisque personne n’a l’air de se plaindre"

C'est si vrai que cela méritait d'être souligné :)